Partial Outage of Timetac
Incident Report for TimeTac
Resolved
We've verified that affected accounts are reachable again.
Posted Mar 13, 2024 - 00:47 CET
Monitoring
We've enabled our fallback system and are watching accounts becoming available again as expected.
Posted Mar 13, 2024 - 00:35 CET
Investigating
Timetac is unavailable for a part of our customer base as a result of our maintenance. We are currently investigating the issue and checking our fallback system.
Posted Mar 13, 2024 - 00:32 CET
This incident affected: Data center: NBG and Data center: FSN.