Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 08, 2024 - 05:30 CET
Scheduled
Our infrastructure provider is undergoing scheduled maintenance. This may affect connectivity to our services and lead to service interruptions for our customers.
Posted Oct 24, 2024 - 10:23 CEST
This scheduled maintenance affected: Data center: NBG and Data center: FSN.