Scheduled Maintenance of production environment

Incident Report for TimeTac

Resolved

This incident has been resolved.
Posted Apr 15, 2026 - 02:21 CEST

Investigating

The maintenance is taking longer than expected, and we need to extend the maintenance window. We appreciate your patience and will provide updates as soon as possible.
Posted Apr 15, 2026 - 00:02 CEST
This incident affected: Data center: NBG, Data center: FSN, Testenvironment - Sandbox, TimeTac homepage (www.timetac.com), and TimeTac knowledgebase (support.timetac.com).