A fix has been implemented and we are monitoring the results.
Posted May 10, 2026 - 15:07 CEST
Investigating
We are currently experiencing a partial outage affecting one of our servers. Some functionality may be limited. Our team is working to restore full service and we will post updates here as we make progress.
Posted May 10, 2026 - 14:52 CEST
This incident affected: Data center: NBG and Data center: FSN.