Investigating — intermittent connectivity for some European customers

Incident Report for TimeTac

Resolved

Intermittent connectivity issues affecting access to go.timetac.com, app.timetac.com, and api.timetac.com from some European regions have been resolved.
Posted May 17, 2026 - 19:11 CEST

Investigating

We are aware of intermittent connection timeouts affecting some European customers when accessing TimeTac (go.timetac.com, app.timetac.com, api.timetac.com).
The root cause has been identified as a network infrastructure issue at our hosting provider's European network. Our application is fully operational and your data is safe — the issue affects only the network path between certain networks and our servers.
Posted May 17, 2026 - 09:55 CEST