Degraded Performance

Incident Report for TimeTac

Resolved

This incident has been resolved.
Posted Nov 03, 2025 - 15:32 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 03, 2025 - 14:04 CET

Identified

We are currently experiencing degraded performance affecting parts of our infrastructure. Some services may respond slowly or be intermittently unavailable. Our engineering team is investigating the issue and working to restore normal performance as quickly as possible.
Posted Nov 03, 2025 - 11:19 CET
This incident affected: Data center: NBG and Data center: FSN.